[!] CocoaPods could not find compatible versions for pod “firebase_auth”:
In Podfile:
firebase_auth (from .symlinks/plugins/firebase_auth/ios)

「[!] CocoaPods could not find compatible versions for pod “firebase_auth”:<br>In Podfile:<br>firebase_auth (from <code>.symlinks/plugins/firebase_auth/ios</code>)」のアイキャッチ画像

flutterに

firebase入れようとしたらタイトルのエラー発生

# platform :ios, '9.0' から platform :ios, '10.0'に変更

platform :ios, '10.0'

pod repo update
rm -rf Podfile.lock
pod install

これで通りました

参考記事

CocoaPods could not find compatible versions for pod “Firebase/CoreOnly”